CSS first-line pseudo-element

Last updated on : 2022-04-10

Note:
CSS first-line pseudo-element shows a browser compatibility score of 100. This is a collective score out of 100 to represent browser support of a web technology. The higher this score is, the greater is the browser compatibility. The browser compatibility score is not a 100% reflection for every browser and the web technology support. However, it does give you an estimate on how much you should rely on a particular web technology in terms of browser compatibility.

Overview

The CSS ::first-line pseudo-element can be used to style the first letter or first line of text on an element. However, can be applied to a limited set of properties.

Specifications

CSS Pseudo-Elements Module Level 4 # first-line-pseudo

Syntax

/* CSS3 syntax */
 ::first-line /* CSS2 syntax */
 :first-line

Browser Compatibility

  • CSS first-line pseudo-element on IE is fully supported on 9-11, partially supported on 5.5-8, and not supported on below 5.5 IE versions.
  • CSS first-line pseudo-element on Edge is fully supported on 12-99, partially supported on None of the versions, and not supported on below 12 Edge versions.
  • CSS first-line pseudo-element on Firefox is fully supported on 2-100, partially supported on None of the versions, and not supported on below 2 Firefox versions.
  • CSS first-line pseudo-element on Chrome is fully supported on 4-103, partially supported on None of the versions, and not supported on below 4 Chrome versions.
  • CSS first-line pseudo-element on Safari is fully supported on 3.2-15.4, partially supported on None of the versions, and not supported on below 3.2 Safari versions.
  • CSS first-line pseudo-element on Opera is fully supported on 9.5-83, partially supported on None of the versions, and not supported on below 9.5 Opera versions.
  • CSS first-line pseudo-element on Safari on iOS is fully supported on 3.2-15.4, partially supported on None of the versions, and not supported on below 3.2 Safari on iOS versions.
  • CSS first-line pseudo-element on Android Browser is fully supported on 2.3-99, partially supported on None of the versions, and not supported on below 2.3 Android Browser versions.
  • CSS first-line pseudo-element on Opera Mobile is fully supported on 10-64, partially supported on None of the versions, and not supported on below 10 Opera Mobile versions.
  • CSS first-line pseudo-element on Chrome for Android is fully supported on 97-100, partially supported on None of the versions, and not supported on below 97 Chrome for Android versions.
  • CSS first-line pseudo-element on Firefox for Android is fully supported on 95-98, partially supported on None of the versions, and not supported on below 95 Firefox for Android versions.
  • CSS first-line pseudo-element on Samsung Internet is fully supported on 4-16, partially supported on None of the versions, and not supported on below 4 Samsung Internet versions.
100
Hightooltip

Browser Compatibility Score

Chrome IE
High

Browser Support For IE Versions

9-11
Fully
5.5-8
Partially
-
No Support
Chrome Edge
High

Browser Support For Edge Versions

12-99
Fully
-
Partially
-
No Support
Chrome Firefox
High

Browser Support For Firefox Versions

2-100
Fully
-
Partially
-
No Support
Chrome Chrome
High

Browser Support For Chrome Versions

4-103
Fully
-
Partially
-
No Support
Chrome Safari
High

Browser Support For Safari Versions

3.2-15.4
Fully
-
Partially
-
No Support
Chrome Opera
High

Browser Support For Opera Versions

9.5-83
Fully
-
Partially
-
No Support
Chrome Safari on iOS
High

Browser Support For Safari on iOS Versions

3.2-15.4
Fully
-
Partially
-
No Support
Chrome Android Browser
High

Browser Support For Android Browser Versions

2.3-99
Fully
-
Partially
-
No Support
Chrome Opera Mobile
High

Browser Support For Opera Mobile Versions

10-64
Fully
-
Partially
-
No Support
Chrome Chrome for Android
High

Browser Support For Chrome for Android Versions

97-100
Fully
-
Partially
-
No Support
Chrome Firefox for Android
High

Browser Support For Firefox for Android Versions

95-98
Fully
-
Partially
-
No Support
Chrome Samsung Internet
High

Browser Support For Samsung Internet Versions

4-16
Fully
-
Partially
-
No Support

Test your website on 3000+ browsers

Test your website on 3000+ real browsers and operating systems for mobile and desktop with the LambdaTest cloud. Perform browser compatibility test for CSS first-line pseudo-element and many more web technologies that are a part of your website or web-application.

Last Modified date

2022-04-10

Browser Support for CSS first-line pseudo-element

  • ChromeChrome
  • Safari Safari
  • Firefox Firefox
  • IE Internet Explorer
  • Opera Opera
  • Edge Edge

References


Data sourced from

Test on a Real Browser

Test this and other features on your website for compatibility across
3,000 real browsers and devices using

Try LambdaTest
LambdaTestX

We use cookies to give you the best experience. Cookies help to provide a more personalized experience and relevant advertising for you, and web analytics for us. Learn More in our Cookies policy, Privacy & Terms of service

Allow Cookie
Sarah

I hope we're able to help you build browser compatible web experience.

Fast track your browser testing experience on 3000+ browsers and OS combinations with LambdaTest.

Sarah Elson (Product & Growth Lead)