How to use n_list method in avocado

Best Python code snippet using avocado_python

3085.py

Source:3085.py Github

copy

Full Screen

1# '''2# 문제3# 상근이는 어렸을 적에 "봄보니 (Bomboni)" 게임을 즐겨했다.4#5# 가장 처음에 N×N크기에 사탕을 채워 놓는다. 사탕의 색은 모두 같지 않을 수도 있다. 상근이는 사탕의 색이 다른 인접한 두 칸을 고른다.6# 그 다음 고른 칸에 들어있는 사탕을 서로 교환한다. 이제, 모두 같은 색으로 이루어져 있는 가장 긴 연속 부분(행 또는 열)을 고른 다음 그 사탕을 모두 먹는다.7#8# 사탕이 채워진 상태가 주어졌을 때, 상근이가 먹을 수 있는 사탕의 최대 개수를 구하는 프로그램을 작성하시오.9#10# 입력11# 첫째 줄에 보드의 크기 N이 주어진다. (3 ≤ N ≤ 50)12#13# 다음 N개 줄에는 보드에 채워져 있는 사탕의 색상이 주어진다. 빨간색은 C, 파란색은 P, 초록색은 Z, 노란색은 Y로 주어진다.14#15# 사탕의 색이 다른 인접한 두 칸이 존재하는 입력만 주어진다.16#17# 출력18# 첫째 줄에 상근이가 먹을 수 있는 사탕의 최대 개수를 출력한다.19#20# 예제 입력 121# 522# YCPZY23# CYZZP24# CCPPP25# YCYZC26# CPPZZ27# 4*528# 4*529# n*(n-1)+n*(n-1)30#31# 예제 출력 132# 433# 힌트34# 4번 행의 Y와 C를 바꾸면 C사탕 네 개를 먹을 수 있다.35# '''36#37#38#39#40#41#42#43#44#45#46#47# global max_cnt48# max_cnt = 049#50# T_array= []51# line = int(input())52# for i in range(line):53# temp = ""54# temp = input()55# temp_list = []56# temp_list = list(temp)57# T_array.append(temp_list)58#59# def move():60# global max_cnt61# for row in range(line):62# for col in range(line):63# if col+1 < line:64# T_array[row][col], T_array[row][col+1] = T_array[row][col+1], T_array[row][col]65# max_cnt = search()66# T_array[row][col+1], T_array[row][col] = T_array[row][col], T_array[row][col+1]67#68# for row in range(line):69# for col in range(line):70# if col+1 < line:71# T_array[col][row], T_array[col+1][row] = T_array[col+1][row], T_array[col][row]72# max_cnt = search()73# T_array[col][row], T_array[col+1][row] = T_array[col+1][row], T_array[col][row]74#75# return max_cnt76#77# def search():78# global max_cnt79# for row in range(line):80# for col in range(line):81# c_row_cnt = 082# p_row_cnt = 083# z_row_cnt = 084# y_row_cnt = 085#86# c_col_cnt = 087# p_col_cnt = 088# z_col_cnt = 089# y_col_cnt = 090#91#92# if T_array[row][col] == 'C':93# c_row_cnt += 194# elif T_array[row][col] == 'P':95# p_row_cnt += 196# elif T_array[row][col] == 'Z':97# z_row_cnt += 198# elif T_array[row][col] == 'Y':99# y_row_cnt += 1100# elif T_array[col][row] =='C':101# c_col_cnt += 1102# elif T_array[col][row] == 'P':103# p_col_cnt += 1104# elif T_array[col][row] == 'Z':105# z_col_cnt += 1106# elif T_array[col][row] == 'Y':107# y_col_cnt += 1108# temp_cnt = max(c_row_cnt,z_row_cnt,p_row_cnt,y_row_cnt,c_col_cnt,p_col_cnt,z_col_cnt,y_col_cnt)109# if temp_cnt > max_cnt:110# return temp_cnt111# else:112# return 0113#114#115#116# print(move())117'''118N * N 행렬(이차원 배열)등장1191. 입력을 받아 2차원 배열 완성1202. 행,열 기준 N-1번 바꾸는 경우의 수 존재 -> for문, 1번 바꿀때 마다 검사1213. 바꾸면 사탕의 최대 개수 검사(행,렬) -> 연속된 색깔을 어떻게 선별? -> 색깔 별로 변수를 만들어서 연속되면 +=1 해줌1225123YCPZY124CYZZP125CCPPP126YCYZC127CPPZZ128'''129C_cnt, P_cnt, Z_cnt, Y_cnt = 1, 1, 1, 1130def loop(N, N_list):131 for i in range(N):132 for j in range(N-1):133 row_search(N_list, i)134 col_search(N_list, j)135 #행검사136 N_list[i][j], N_list[i][j+1] = N_list[i][j+1], N_list[i][j]137 row_search(N_list,i)138 col_search(N_list,j)139 N_list[i][j+1], N_list[i][j] = N_list[i][j], N_list[i][j+1]140 # print(N_list[i][j])141 #열 검사142 N_list[j][i], N_list[j+1][i] = N_list[j+1][i], N_list[j][i]143 col_search(N_list, j)144 row_search(N_list, i)145 N_list[j+1][i], N_list[j][i] = N_list[j][i], N_list[j+1][i]146 # for i in range(N):147 # for j in range(N-1):148 # #열 검사149 # N_list[j][i], N_list[j+1][i] = N_list[j+1][i], N_list[j][i]150 # col_search(N_list, j)151 # row_search(N_list, i)152 # N_list[j+1][i], N_list[j][i] = N_list[j][i], N_list[j+1][i]153 # print(N_list[j][i])154def row_search(N_list,l):155 global C_cnt156 global P_cnt157 global Z_cnt158 global Y_cnt159 temp_c, temp_p, temp_z, temp_y = 1, 1, 1, 1160 for i in range(len(N_list) - 1):161 if N_list[l][i] == N_list[l][i + 1]:162 if N_list[l][i] == 'C':163 temp_c += 1164 elif N_list[l][i] == 'P':165 temp_p += 1166 elif N_list[l][i] == 'Z':167 temp_z += 1168 elif N_list[l][i] == 'Y':169 temp_y += 1170 if C_cnt < temp_c:171 C_cnt = temp_c172 if P_cnt < temp_p:173 P_cnt = temp_p174 if Z_cnt < temp_z:175 Z_cnt = temp_z176 if Y_cnt < temp_y:177 Y_cnt = temp_y178def col_search(N_list,l):179 global C_cnt180 global P_cnt181 global Z_cnt182 global Y_cnt183 temp_c, temp_p, temp_z, temp_y = 1, 1, 1, 1184 for i in range(len(N_list) - 1):185 if N_list[i][l] == N_list[i + 1][l]:186 if N_list[i][l] == 'C':187 temp_c += 1188 elif N_list[i][l] == 'P':189 temp_p += 1190 elif N_list[i][l] == 'Z':191 temp_z += 1192 elif N_list[i][l] == 'Y':193 temp_y += 1194 if C_cnt < temp_c:195 C_cnt = temp_c196 if P_cnt < temp_p:197 P_cnt = temp_p198 if Z_cnt < temp_z:199 Z_cnt = temp_z200 if Y_cnt < temp_y:201 Y_cnt = temp_y202if __name__ == '__main__':203 N = int(input())204 N_list = [list(input()) for i in range(N)]205 loop(N, N_list)206 print(max(C_cnt, P_cnt, Z_cnt, Y_cnt))207 print(C_cnt, P_cnt, Z_cnt, Y_cnt)208'''2095210CPZCC211ZYCPZ212CYYPZ213ZPZCC214CCPYY...

Full Screen

Full Screen

AA.py

Source:AA.py Github

copy

Full Screen

1# def padding(n, n_list):2# cnt = 03# pad_list = [0 for _ in range(n + 2)]4# n_list.insert(0, pad_list)5# n_list.append(pad_list)6# for idx in range(1, n + 1):7# n_list[idx].insert(0, 0)8# n_list[idx].append(0)9# for i in range(1, n + 1):10# for j in range(1, n + 1):11# print(12# n_list[2][1]13# == max(14# n_list[1][1],15# n_list[1][0],16# n_list[1][2],17# n_list[0][1],18# n_list[2][1],19# )20# )21# if n_list[i][j] == max(22# [23# n_list[i][j],24# n_list[i - 1][j],25# n_list[i + 1][j],26# n_list[i][j + 1],27# n_list[i][j - 1],28# ]29# ):30# cnt += 131# return cnt32# n = int(input())33# n_list = [list(map(int, input().split())) for _ in range(n)]34# print(padding(n, n_list))35# print(n_list)36# print(pad_list)37# 두 번째 풀이38dx = [-1, 0, 1, 0]39dy = [0, 1, 0, -1]40n = int(input())41n_list = [list(map(int, input().split())) for _ in range(n)]42n_list.insert(0, [0] * n)43n_list.append([0] * n)44for sub in n_list:45 sub.insert(0, 0)46 sub.append(0)47cnt = 048for i in range(1, n + 1):49 for j in range(1, n + 1):50 if all(n_list[i][j] > n_list[i + dx[k]][j + dy[k]] for k in range(4)):51 cnt += 1...

Full Screen

Full Screen

passwordDecryption.py

Source:passwordDecryption.py Github

copy

Full Screen

1# Coded by SpiderX23n = input("")4n_list = list(n)5new = []67for i in range(len(n_list)):8 if n_list[i] == "*":9 pass1011 elif str(n_list[i]).islower() and str(n_list[i+1]).isupper():12 n_list[i], n_list[i+1] = n_list[i+1], n_list[i]13 n_list.insert((i+2), "*")1415 elif str(n_list[i]).isnumeric():16 # n_list.insert(0, n_list[i])17 new.insert(0, n_list[i])18 n_list[i] = str(0)1920 else:21 pass222324print(*new, *n_list, sep="") ...

Full Screen

Full Screen

Automation Testing Tutorials

Learn to execute automation testing from scratch with LambdaTest Learning Hub. Right from setting up the prerequisites to run your first automation test, to following best practices and diving deeper into advanced test scenarios. LambdaTest Learning Hubs compile a list of step-by-step guides to help you be proficient with different test automation frameworks i.e. Selenium, Cypress, TestNG etc.

LambdaTest Learning Hubs:

YouTube

You could also refer to video tutorials over LambdaTest YouTube channel to get step by step demonstration from industry experts.

Run avocado automation tests on LambdaTest cloud grid

Perform automation testing on 3000+ real desktop and mobile devices online.

Try LambdaTest Now !!

Get 100 minutes of automation test minutes FREE!!

Next-Gen App & Browser Testing Cloud

Was this article helpful?

Helpful

NotHelpful